
CodePadHelp Index
The Index contains a list of    Help topics available for the CodePad text editor.    You can 
use the scroll bar to see the entries that are not currently visible in the Help window.

Keyboard
CodePad Keys

Commands
Edit Menu
File Menu
Search Menu Commands
View Menu

Procedures
Copying, Cutting, and Pasting Text
Creating a New Source File
Customizing the CodePad Display
Deleting Text
Exiting CodePad
Finding Text Strings
Formatting Source Code
Getting SDK Help on a Topic
Locating Matching Braces
Locating Text by Line Number
Moving Around in Source Files
Opening Existing Source Files
Printing Source Files
Replacing Text
Running SDK Help
Saving Your Work
Searching for and Replacing Text
Selecting and Marking Text
Setting Up    WIN.INI Extensions
Undoing Edits



CodePadCommands
To get help with a command, click on one of the following:

File Menu Commands
New
Open
Save
Save As
Print
Exit

Edit Menu Commands
Undo
Cut
Copy
Paste
Delete

Search Menu Commands
Find
Find Next
Find Previous
Match Brace
Go To Line
Change

View Menu Commands
Courier 10
Courier 12
Terminal 6
Terminal 10
System

Options Menu Commands
Eight Space Tabs
Four Space Tabs
Save Setup

Help Menu Commands
SDK Index
SDK Topic



CodePadProcedures
The following procedures give you step-by-step instructions for using CodePad. Use the 
scroll bar to see more topics.

Editing
Copying, Cutting, and Pasting Text
Deleting Text
Formatting Text
Replacing Text
Selecting and Marking Text
Undoing Edits

Searching
Finding Text Strings
Getting SDK Help on a Topic
Locating Matching Braces
Locating Text by Line Number
Moving Around in Source Files
Running SDK Help
Searching for and Replacing Text

Working with Source Files
Creating a New Source File
Exiting
Opening Existing Source Files
Printing Source Files
Saving Your Work

Setting UpCodePad
Customizing the CodePad Display
Setting Up    WIN.INI Extensions



Edit Menu Commands
Use the scroll bar to see more information.

Undo
Undoes your last editing action.
You can undo:
 * Text edits.
 * Cut and Paste actions. 

Note: If there are no edits to undo, Undo appears dimmed on the Edit menu.
Related Topics
Undoing Edits

Cut
Deletes text from the current edit window and places it in the Clipboard, erasing the 
previous Clipboard contents.
Use Paste to insert the cut text in the same edit window, another window, or another 
application.
Related Topics
Deleting Text

Copy
Copies text from an edit window into the Clipboard, leaving the original text intact and 
erasing the previous Clipboard contents.
Use Paste to place the copied text in the same file, another file, or another application.
Related Topics
Copying, Cutting, and Pasting Text

Paste
Pastes a copy of the Clipboard contents at the insertion point or replaces selected text in a
file.
Related Topics
Copying, Cutting, and Pasting Text

Delete
Deletes selected text from an edit window, but does not copy the selection into the 
Clipboard.
Use Delete when you have something in the Clipboard that you want to keep, but want to 
delete something else from the current CodePadfile.
Related Topics
Deleting Text



File Menu Commands
Use the scroll bar to see more information.

New
Starts a new source file.
When you choose New, CodePad lets you save changes to the current file.
Related Topics
Creating a New Source File

Open
Opens an existing text file.
When you choose Open, CodePad lets you save changes to the current file.
Related Topics
Opening Existing Source Files

Save
Saves changes to the current file.
When you choose Save, the file remains open so you can continue working on it.
Related Topics
Saving Your Work

Save As
Saves a new or existing file.
You can:
 * Name a new file.
 * Save an existing file under a new name.

Note: The original remains unchanged.
Related Topics
Saving Your Work

Print
Prints one copy of the current file.
Related Topics
Printing Source Files

Exit
Closes the current file and exits CodePad.
If the file is unsaved, CodePad lets you save it before exiting.
Related Topics
Exiting CodePad



Search Menu Commands
Use the scroll bar to see more information.

Find
Searches for characters or words in a file.
Related Topics
Finding Text

Find Next
Repeats the last search in the forwards direction without opening the Find dialog box.

Find Previous
Repeats the last search in the backwards direction without opening the Find dialog box.

Match Brace
Finds the opposite brace, bracket, or parenthesis corresponding to the one selected.
Related Topics
Locating Matching Braces

Go To Line
Go to a specified line number in the source code.
Related Topics
Locating Text by Line Number

Change
Searches for characters or words in a file and replaces selected occurrences with new text.
Related Topics
Searching for and Replacing Text



View Menu Commands
Allows you to customize the CodePad screen display by selecting the best screen font for 
your needs.

You can choose from the following mono-spaced fonts:
 * Courier 10
 * Courier 12
 * Terminal 6
 * Terminal 10
 * System
These selections only change the way source code is displayed and do not affect the 
source file.
Related Topics
Customizing the CodePad Display



Options Menu Commands

Eight Space Tabs
Sets tab stops every eight characters. 

Four Space Tabs
Sets tab stops every four characters.

Save Setup
Use this command to make the current setup options permanent.    When CodePad is run 
again it will use the saved settings.    The following setup options are saved:
 * The current Tab Settings.
 * The current Screen Display Font.
 * The current window size.

Note: Used as a maximum for future editing sessions.
Related Topics
Customizing the CodePad Display



Help Menu Commands
Allows you to access the Windows Software Development Kit help file from 
withinCodePad.The Windows Help Program must be able to locate the SDKWIN.HLP file by 
using your PATH variable.
Note: You must have installed the Windows SDK in order to use this feature.

SDK Index
Displays the SDK help file index. 

SDK Topic
Displays the SDK manual page for the selected topic.
Use the mouse or keyboard to select a function name, macro, or data type in your program
text. 
Related Topics
Selecting and Marking Text



Copying, Cutting, and Pasting Text

To copy and paste or cut and paste text:
1 Select the text.
2 Choose Copy from the Edit menu to copy text.

Or choose Cut to cut text.
3 Move the insertion point where you want the text to appear.

Or select text you want to replace.
4 Choose Paste from the Edit menu.

1 Select the text to cut or copy.
2 Point to where you want the text to appear.    Hold down the Alt key and press the mouse

button to copy text.
Or hold down Ctrl+Alt and press the mouse button to cut and paste text.



Creating New Source Files

To create a new file:
 * Choose New from the File menu.
Related Topics
Opening Existing Source Files



Customizing the CodePad Screen Display

To change the screen display font:
 * Choose a font from the View menu.

To change tab settings:
 * Choose a Tab Spacing from the Options menu.

To make settings permanent:
 * Choose Save Setup from the Options menu.
Related Topics
Options Menu Commands



Deleting Text

To delete one character at a time:
 * Press Backspace to delete the character to the left of the insertion point.
 * Press Delete to delete the character to the right of the insertion point.

To delete more than one character:
1 Select the text you want to delete.
2 Press Backspace or Delete.

Or choose Cut from the Edit menu to place the text in the Clipboard.
Or choose Delete to delete the text, without affecting the Clipboard.

Related Topics
Copying, Cutting, and Pasting Text



Exiting CodePad

To exit fromCodePad:
* Choose Exit from the File menu.

 * Double-Click on the Control-menu box in the upper left hand corner of your window.
You will always be given a chance to save your changes if you have not already done so.
Related Topics
Saving Your Work



Finding Text

To find specific characters or words:
1 Move the insertion point where you want the search to begin.
2 Choose Find from the Search menu.
3 Type the characters or words you want to find.
4 Select Case Sensitive to match upper and lower cases exactly.
5 Choose Next or Previous to search forward or backward.
6 Choose Find Next or Previous from the Search menu to find more occurrences.

To find more text matching text already on your screen:
1 Select the text that you wish to find.
2 Choose Find Next or Previous from the Search menu.

To find text in a second window that matches text in the first:
1 Select the text that you wish to find in the first window.
2 Choose Find Next or Previous from the Search menu of the second window.Note: Before 

searching in the second window make sure that no text is selected in it.
Related Topics
Searching for and Replacing Text



Formatting Source Code
In Order To Do this
Insert a space Press Spacebar.
End a line Press Enter.
Indent a line Press Tab.
Insert a tab Press Tab.
Insert a blank line Move the insertion point to the beginning of a line and press Enter.
Split a line Move the insertion point to the beginning of the text you want to move 

to the next line and press Enter.
Join two lines Move the insertion point to the beginning of the line you want to move.    

Press Backspace until the lines are joined.



Getting SDK Help for a Topic

To get SDK help on a term in your program text:
 1 Select the function name, macro or term in your program.

Note: to select an entire word you can double click on it with the mouse.
2 Choose SDK Topic from the Help menu.
Related Topics
Running SDK Help



Locating Matching Braces

To Locate a matching brace, bracket, or parenthesis:
1 Select the brace you want to match.
2 Choose Match Brace from the Search menu.



Locating Text by Line Number
The insertion point line number is displayed on the right-hand side of the menu-bar.
* Black numbers represent the location of the insertion point (when it is on the screen).
* When the insertion point is not visible, a greyed number represents the line number at    

the middle of the screen. 

To go to a specific line number:
1 Choose Go To Line from the Search menu.
2 Enter the line number you want to go to and press enter.

1 Move the vertical scroll bar until the greyed line number approximates the one you are 
seeking.

2 Click with the mouse near the center of the screen.
3 Move the cursor up or down until the number is reached.



Moving Around in Source Files

To browse or move through a source file:
 * Move either the horizontal or vertical scroll bars.
 * Use the Page Up or Page Down keys.
 * Use the Home or End keys.
 * Use Ctrl+Home or Ctrl+End.
 * If the insertion point is off the screen, moving it    with one of the cursor keys will take 

you there.

 * Click once on any of the four client area margins.
Related Topics
CodePad Keys



Opening Existing Source Files
CodePadworks with text or ASCII files only. 

To open an existing source file:
1 Choose Open from the File menu.
2 Enter the filename.
3 Choose OK.

 * Double-click on a filename in the Window's File Manager .
Related Topics
Setting Up WIN.INI Extensions
Creating New Source Files



Printing Source Files

To print one copy of the current file:
 * Choose Print from the File menu.
Files are printed using the default printer's default font .



Replacing Text

To replace text:
1 Select the text to be replaced.
2 Type over the selected text.

Or paste into the selected text.
Related Topics
Searching and Replacing Text



Running SDK Help

To run SDK help fromCodePad:
 * Choose SDK Index from the Help menu.
Related Topics
Getting SDK Help for a Topic



Saving Your Work

To save changes to the current file:
 * Choose Save from the File menu.

To save the current work under a new name:
1 Choose Save As from the File menu.
2 Enter a filename.
3 Choose OK.

How to tell if a file has modified since the last save:
* The ± symbol is displayed in the lower right hand corner of the window.
* The CodePad Icon has writing on it.
Related Topics
Exiting CodePad



Searching for and Replacing Text

To search for a text string and replace it with another:
1 Move the insertion point to where you want the search to begin.
2 Choose Change from the Search menu.
3 Type the text you want to find and change.
4 Type the replacement text.
5 Select Case Sensitive to match upper and lower cases exactly.
6 Choose Find Next to find the first occurrence of the search string.
7 Thereafter, choseSkip to skip over matches.

Or choose Change to make the change.
Or choose Change All to make all of the changes at once.
Note:Once the Change Box has been filled out    its values are made available to all otherCodePadwindows.

 * You may select the search text with the mouse before entering the Change command.
Related Topics
Finding Text Strings



Selecting and Marking Text

To select text for editing:
* Hold down the Shift key and use one of the arrow keys.
* Use the Shift key + one of: Page UP, Page Down, Home or End.

 * Press the Mouse button down on the first point and drag the mouse to the end of the 
text, then release the mouse button.

 * The Shift key may be held down while clicking and dragging with the mouse in order to 
extend the selection.

* You can select whole lines by dragging the mouse cursor along the left margin of the 
client area.

* To select a whole word double-click on it.
Related Topics
CodePad Keys



Setting Up WIN.INI Extensions

Setting up CodePad under Microsoft Windows:
 * Change the [extensions] section of your win.ini file to run CodePad. An extension entry 

has the form:    
ext=codepad.exe ^.ext

Double-clicking on any file having the extension ext, will run CodePad on that file .
If you use CodePad for programming under Microsoft Windows then you should set up as 
many extensions as possible.    This will allow you to move from file to file by just double 
clicking on filenames in an MS-DOS Executive or File Manager window.
The following list of extensions has been included to help you get started.      You can use 
the Help system Edit Copy command to copy this list into the clipboard before inserting 
them into your win.ini file.

[Extensions]
.=codepad.exe ^.
asm=codepad.exe ^.asm
bat=codepad.exe ^.bat
c=codepad.exe ^.c
dat=codepad.exe ^.dat
def=codepad.exe ^.def
dlg=codepad.exe ^.dlg
h=codepad.exe ^.h
hpj=codepad.exe ^.hpj
ini=codepad.exe ^.ini
ini=codepad.exe ^.ini
log=codepad.exe ^.log
me=codepad.exe ^.me
mon=codepad.exe ^.mon
new=codepad.exe ^.new
old=codepad.exe ^.old
out=codepad.exe ^.out
rc=codepad.exe ^.rc
ref=codepad.exe ^.ref
sav=codepad.exe ^.sav
sys=codepad.exe ^.sys
txt=codepad.exe ^.txt
x=codepad.exe ^.x
y=codepad.exe ^.y
z=codepad.exe ^.z



Undoing Edits

To undo your last edit:
 * Choose Undo from the Edit menu.



CodePadKeys
Use the following keys inCodePad.

Moving the Insertion Point
Key(s) Function
Up Arrow Moves the insertion point up one line.
Down Arrow Moves the insertion point down one line.
Right Arrow Moves the insertion point to the right one character.
Left Arrow Moves the insertion point to the left one character.
Home Moves to the beginning of the line.
End Moves to the end of a line.
Page Up Moves up one window.
Page Down Moves down one window.
Ctrl+Home Moves to the beginning of    the file.
Ctrl+End Moves to the end of the file.

Selecting Text
Key(s) Function
Shift+Left or Right Arrow Selects text one character at a time to the left or right.
Shift+Down or Up Selects text one line at a time up or down.
Shift+End Selects text to the end of the line.
Shift+Home Selects text to the beginning of the line.
Shift+Page Down Selects or deselects text down one window.
Shift+Page UP Selects or deselects text up one window.

Editing Keys
Key(s) Function
Backspace Deletes the character to the left of the insertion point.
Delete Deletes the character to the right of the insertion point.
Alt+Left Mouse Click Copies selected text to the insertion point.
Ctrl+Alt+Left Mouse Click Moves selected text to the insertion point.



Client Area
A rectangular area where you can enter and display text.    The client area is surrounded by
a narrow margin which you may click on with the mouse in order to scroll one line or 
character.



Clipboard
The clipboard is the cut/paste buffer used to hold text between the cut/copy and paste 
operations.    You can cut/copy and paste text between CodePad applications, or between 
CodePad and other applications.    
The same clipboard is also used for cutting and pasting within a single CodePad 
application.


